Unbrick help! OP 6T stuck at fastboot

!!A6013 model!!

What happened;

1.i unlocked boot loader
2.Installed twrp
3.Installed magisk manager
4.Then installed magisk.zip from twrp
5.Wifi & call stopped working,

I flashed modem.img from fastboot
It restarted but it didn’t fixed wifi & calling
Then I i tried to unroot ( i forgot how i tried )

Currently!!! ;;;;-----
Whenever i start the OP6t, it gets stuck at fastboot

Failed tries:-

  1. Tried to unbrick via msm tool 4.0 factory, it says image not matched & it stops. ( All msm files at google)
  2. Tried flashing stock firmware, ( didn’t work)

Max my man, help me

1 Like

You can use fastboot to flash the stock firmware. Let me give you the script. Give me a few minutes, I am taking a dump atm.

2 Likes

I’ve tried full.bat auto cmd to install it, it fails.
I tried installing twarp by putting in platform tools & giving command: fastboot boot twarp.img, it failed too.
What the other way?
There is some error about partition, i think i may have booted a kernel & now I can’t boot stock kernel straight away, help me unbrick it from fastboot, max!

1 Like

Max, help! I’m waiting…:grimacing:

1 Like

Did u try to format data then reinstall factory zip in twrp??

2 Likes

How can I format data when I am stuck in fastboot, as soon as I start it comes back to fastboot ( which means it doesn’t go to recovery)
I tried fastboot boot twrp—.img but it gives error

1 Like

Have you tried - fastboot flash recovery twrp-x.x.x-xxx.img (name of TWRP file) That should remove root when flashed. But, someone correct me if I’m incorrect in this instance.

I tried, it makes some kind of partition or directory issue, i tried it like 10 times, i never goes back to twrp recovery from fastboot

1 Like

That should install/flash TWRP, then fastboot boot twrp—.img should boot into TWRP. Not sure past that. Sorry.