(Solved) How do you flash a gsi?

Max videos are seemingly obsolete anyone any ideas ?

Both for me and another forum member

So far i have gathered that u need to do it using adb/fastboot (twrp) method doesnt work.

u need something called vbmeta file to stop some kind of protection so u can boot.

Not every gsi will work so if u do get a bootloop try other gsi first.

When u have a phone that is a partition only but if u are running a newer android 10/11 custom rom then u need a a/b partition gsi.

Honestly i am stuck i dont know why it wont work see below for the errors.

also vbmeta flash tried both commands see below

C:\Users\nnnnn>fastboot --disable-verification flash vbmeta C:\Users\nnnnn\Desktop\vbmeta.img
fastboot: unknown option – disable-verification

C:\Users\nnnnn>fastboot flash vbmeta C:\Users\nnnnn\Desktop\vbmeta.img
target reported max download size of 536870912 bytes
sending ‘vbmeta’ (4 KB)…
OKAY [ -0.000s]
writing ‘vbmeta’…
FAILED (remote: Flashing is not allowed for partition
)
finished. total time: 0.016s

(one member said some phones are partly closed so gave a command to open it but didnt work because my phoen was already completly open)

C:\Users\nnnnn>fastboot erase userdata(-w)
erasing ‘userdata(-w)’…
FAILED (remote: No such partition.)
finished. total time: -0.000s

Flashing of gsi itself does work but just bootloops tried several gsi cause not everyone will work for your phone so i am geussing vbmeta wont flash for me thats what i need to flash gsi succesfully.

Anyone ideas ? @gregoryaul or maybe Max from the youtube videos?

1 Like

Yes GSI is not wildly supported not many devs list the exact method to flash gsi so it makes it tough for usif they would list every file used in flashing GSI on different phones it wouldn’t be so hard

1 Like

Yeah it is very annoying and so little info shame realy.

Anyway i have done it !!!

I stil cant get vbmeta to flash for some reason tried several commands but nothing but i tried the other way wich is to flash magisk wich does pretty much do the same stop the blockage so the gsi can load. and that worked for me i tried several phh treble, linage 18.1 gonna try a couple of others before i go back to regular custom rom.

Edit: twrp method can work if u flash magisk to stop the verification so gsi can load up.

Edit2: should i make a step by step to how i did it ? i could but since i am not a pro maybe i shouldnt ?