S8 Only official released binaries after rooting

A tried to root my Galaxy S8 (G950F) using this video: How to Root Galaxy S8/S8+ on Android 9.0 Pie! - YouTube

Everything seemed to work just fine, until I rebooted the phone to fix magisk issue (timestamp: How to Root Galaxy S8/S8+ on Android 9.0 Pie! - YouTube)
But then I got a message on the top of my screen, above the samsung logo: ‘only official released binaries are allowed to be flashed’

Then I tried to enter download mode and tried to flash twrp again, but I got the same message in the log.

Now I’m downloading the official binaries (it’s super slow) and I’ll try to flash those.

Is there anything I can do to get this to work?

Odin ver: Odin3_v3.13.1
Magisk: Magisk-v18.1

Thank you in advance!!!

UPDATE: I don’t know what to do now, but I tried to flash the official files mentioned above and this is what happened:

  1. it started downloading then the previous unofficial message popped up
  2. I tried to reboot it and it entered this strange mode: ‘an error occurred while updating the device software. Use the Emergency recovery function in the smart switch pc software.’
  3. I tried to flash the bootloader in odin (success)
  4. now I’m in the official Android Recovery menu: I rebooted into download mode
  5. I flashed the AP and booted into android successfully

So now the real question: Could you please help me root this phone or should I be happy that I got my os back and never try it again?

I successfully rooted the device

my steps:

(S8; Android 9)


  1. ver. G950FXXUCDUD1
  2. OEM unlock
  3. download mode
    2.1 twrp (AP) flash
    2.1.1 start
    2.2.2 done → power+bixby+volume up
  4. twrp wipe
    3.1 format
    3.2 reboot to recovery (no install)
  5. Magisk-v19.3.zip & no-verity-opt-encrypt-3.1
    4.1 pc → phone
    4.2 install no-verity
    4.3 install magisk
  6. reboot now
    5.1 install twrp