Redmi Note 7 Stuck in EDL Mode

A bootloop Redmi Note 7 was brought to my shop, it is bootloader unlocked and TWRP installed. In an error, i flashed a Redmi 7 file using fastboot commands (flashed one partition after the other since flashall command doesn’t work). Afterwards, the phone get stuck un EDL mode (CANNOT GO INTO FASTBOOT NOR RECOVERY MODE ANYMORE) and i then realised it’s a Note 7. I downloaded the Note 7 (International version) file and flashed with MIflash and also QFIL but still stuck in EDL mode after successful flash. The owner said he noticed CN in the build number and i downloaded the Chinese ROM. There’s a successful flash but I’m still stuck in EDL mode.
Please i need your help.

NB: The IMEI states that the phone is international version when i checked on XIAOMI page.

NBB: In MiFlash, i did not use flash and lock option. I only used flash all.

1 Like

Ok did u try and factory rest after the mi flash prosses was complete?? Some times that helps. Remember ur going from international to chinese rom try that once

Thanks for tour response, there is no way to perform a factory reset because the phone stays in EDL mode even after successful flash. I’ve tried different key combination but could not get it out of EDL Mode.

1 Like

Oh I just found something on redmi note 7 let me share kk

Here watch this kk

Let me know if u have any luck if not I’ll keep looking ok

I heard Chinese models will brick if you flash international firmware and also Xiaomis may brick if you downgrade firmware to previous Android versions. But if it is international model if should be recoverable. Can you access fastboot at all or TWRP?

Still not working please

fI cannot get into fastboot nor enter recovery. It’s hard bricked with only EDL mode.
I think the main cause is the Redmi 7 file i mistakenly flashed .

1 Like

Did u try the international rom and just click clean all only ??

That will keep the bootloader unlock Im thinking it mite unlock it again I’m not say it will but it’s worth a try??

I’ll look on my miflash and see

In your mi flash did u click on chip and make sure you had the correct chipset selected

Thanks for all the responses. I used a tool ‘Miracle Flashing Tool’ to read partitions then wipe all partitions (even though i know sensors and calibration data will be affected). I then flashed with the miracle box and holla, it pop up a charging icon then bootloop. I then go into fastboot and flashed with XiaoMiFlash(Beta). The phone then boot up when it almost complete the flashing operation. I then did a factory wipe.
The phone hs been on Redmi Note 7 boot page since about 30 minutes. I’ll just wait patiently and see if it comes up.
At least, I’m happy there is improvement away from that scary black screen lol.
I’ll probably leave it for several hours, plugged it to power socket already because i don’t know the current battery status.

1 Like

That’s great

U should make a post her it it boots the whole way and make sure people know about this yeeee​:grin::grin::grin:

Holla, Holla, the device is up and running. Though it got locked to MI Account after the owner tried signing in to MI Account. I told him to just use the password recovery option.
I’ll make a full post of my success story from a piece of stone bricked device​:scream: to a shining blue lovely gadget​:grin::grin::grin:

2 Likes

Great job very good

PLEASE READ THROUGH PATIENTLY
This is my first post, hence kindly permit any error made. If anything is not Clear enough, please do not hesitate to ask

So a Redmi Note 7 was brought to my Repair Shop.
Current state

  1. It was in boot loop
  2. Bootloader Unlocked
  3. TWRP already installed.
    In an error, I used fastboot command to flash each flashable partions with a Redmi 7 files and the result wasn’t a pleasant one. The phone became hard brick with no RECOVERY nor FASTBOOT. The only mode i could get into is EDL mode (the black dead screen :grimacing::grimacing::smiling_imp:)

What I Tried

I downloaded stock fastboot firmware and flashed with MiFlash tool and QFIL but kept getting sahara error in both tools. Later found a patched programmer file through google search which I used to replaced the one in the already extracted fastboot firmware.
The RN7 was successfully flashed but still stuck in EDL black screen of death.
Despite knowing the phone is international version (I confirmed that on Xiaomi provided site using the phone’s imei) I flashed the phone with Chinese Version rom and still can’t get a life out of the phone.

What Worked
I used Miracle Tool (if you don’t have the box/dongle, the cracked version will do. Just search it up on google)
I connected the phone in EDL mode and use the Qualcomm interface to read the phone’s partitions, I then wiped all the partitions. (Since the phone plays dead, I decided to kill it completely :grin::grin::joy:.
Afterwards, I flashed the downloaded fastboot firmware with MiFlash tool in EDL mode. The flashing was successful.
The phone boot up but stuck in “Redmi Note 7” boot logo. (At least, I’m on the way up :sunglasses::sunglasses:) I now have access to EDL, RECOVERY and FASTBOOT MODES. A read through google search suggested that the phone was stuck on boot because i wiped “persist”, i tried to flash persist through fastboot but the partition wasn’t flashable.
I used the Miracle Box to re-flash the downloaded firmware but I noticed “persist” was skipped during the Operation.
I then download TWRP and flashed it through fastboot. I boot into TWRP, copied persist.img to the phone and flashed it with TWRP. Afterwards, I wiped Delvi Cache and reboot to system.
The phone boot completely and I’m more than just happy :wink::grin::blush::sunglasses::kissing_heart:.

NB: Before wiping the partitions in Miracle Tool, I’ll suggest you deselect all and select only the core partitions such as system, boot, recovery, cache and userdata. To avoid loosing calibration data and some sensors (promixity, gyroscope etc)

NBB: Confirm your phone version (international, EU, China, India) on the site provided by Xiaomi using your imei in order to save time and mobile data.

Hope this helps someone out there.

1 Like

Thanks for putting solution after, this is gold!

1 Like

version of miracle box?