Problems Loading Fastboot in cmd prompt

Hi, I am fairly new to this and I followed the instructions on How to unlock bootloader on Android but I am having problems with the cd fastboot command on my laptop .
When I enter cmd prompt on my laptop I get C:\users\name>cd Downloads
Then C:\users\name\Downloads>cd fastboot
The system cannot find the path specified
My Android phone is XGODY X10 running android10 go edition, baseband version MOLY.WR8.W1449.MD.WG.M-P.V6.P2
Kernel Version 3.18.19 root@zy-19#2 Wed Apr 7 17:14:11 CST2021
Build Number X5_MT6737M_AA_EMMC_DDR3_64_8_FWVGAP_ZYWY_T62_K_XGODY 20210407-143129
Custom Build alps-mp_-m0.mp1-V2.164.3_nb6737m.35.a.m0

Could someone please explain where I am going or what I am doing wrong

1 Like

Ok hi I’m Greg when u download fastboot.zip u need to extract it and extract it to the downloads folder and keep it there double check and see if it’s in downloads

Thanks Greg for the info, I just checked my downloads and the file is in there and extracted but I have just been watching Max’s video on Utube and think I know where I am going wrong.
I am entering Download instead of downloads, will give it another try and see if that corrects it.
Thanks Again for your help

Just tried it again and still getting The system cannot find the path specified

1 Like

Lol I’ve done that. Before too

Well I have done everything by the book and followed the online instructions and watched the video about it two or three times but still I get the same message in command prompt the system cannot find the path specified

When using file explorer and you look at C:\users\name\downloads folder do you see a fastboot directory (folder)? Or, do you see the unzipped/extracted fastboot file? Or either?
Other way to check is from the command prompt. When in a terminal window at C:\users\name\downloads, issue a Dir command.
From what I have followed so far, you may not have the fastboot directory which would explain the error when issuing a cd command.
Just a few thoughts is all, trying to determine where the fastboot executable file is located. Thanks.

@blueswerks I just checked my downloads file and these are all the files in my Fastboot file


I will try the Dir command as you suggested and let you know what happens
Thanks for your help

@blueswerks just tried what you suggested with the Dir command and this is what happened, think I must be doing something wrong some where.

Thank you. I will do some more research on the syntax needed. Hang in there!

Thanks @blueswerks much appreciated

I found this and it may help, rather than me rewriting the entire process. There are several ways and this may be the one you need: https://www.getdroidtips.com/how-to-install-adb-and-fastboot-on-windows/
If not, please let us know. Thanks!

This may be of help, too: ADB and Fastboot 101

Thanks @blueswerks , I clicked on the link for getdroidstips.com and downloaded the files that they suggested which were compressed zip files but when I unzipped them they were empty and gave me the message that I should download the files needed to this zip folder

This next possibilty was included in the ADB and Fastboot 101 post. How to install Minimal ADB and Fastboot Tool
The link in the article is Download Minimal ADB and Fastboot Tool (all versions)

@Ludeawakening did the post and he is great!

I am having trouble with the adb being recognized in the device manager. My phone shows up but just the name, not the “adb” format. So when I use cmd i get as far as “adb reboot bootloader” and the response that kicks back is “error: nod evices/emulators found” any thoughts?

Hi @geheppo geheppo,
when you extract your zipped files, make sure the only thing you see when you hit “extract to” is 1 folder titled “fastboot”. Dont click into the fastboot folder and then click “extract to”

Also if your “downloads” folder isn’t located in your c drive, youll have to use the “cd” command to change to the appropriate directory.

For example, my downloads directory is in my d drive so for me I have to do the following:
cd /d D:
cd mlapi (which is my user name, yours will be different)
cd downloads
cd fastboot

hope that helps

@A_Eagle,
Thanks for the info, I checked the fastboot and it is located in my downloads in my PC not in my c:drive downloads so I will move it to my C:Drive then give it a try and see what happens.