How to Unroot OnePlus 6 in Bootloop/Hard-Brick!


#1

Originally published at: http://highonandroid.com/android-smartphones/how-to-unroot-oneplus-6-in-bootloop-hard-brick/

There are times where your rooted OnePlus 6 may be in a permanent bootloop situation. No matter what you do, including trying to unroot using TWRP or even trying the fastboot unroot method, it may still be in a bootloop or in other words, “hard brick”. Before crying on your mom’s shoulder or your wife’s…


#2

Video Tutorial:


Flash chinese OnePlus 6
#3

Max, I’m having an issue when I use the MSM tool. It connects fine and gets close to finishing, but then the phone always disconnects after around 200 seconds and gives “FirehoseCheckRSP Failed, Errno: 258”. Phone is hard bricked and I don’t see any other option.


#4

Did you try another computer?


#5

Yup! That’s exactly what fixed my problem. Thanks for the advice though, appreciate the reply. I’m just really happy I no longer have a brick!


#6

I cant flash Oxygen os via the update menu on the op6. So i open the bootloader, installed twrp and flash Oxygen via twrp. Today i want to calibrate my Battery so i discharge it to zero. I pluged my charger in but it wont show the bettery symbol. it just show the “Your boorloader is unlocked” Screen and freeze there. I can start my phone with the power button. But i want to charge it when its turned off.


#7

It should charge regardless are you using OnePlus original charger?


#8

i fixed it.
I had Lineageos installed before. And then wanted to go back to Stockrom. I solved my problem by simply flashing the stockrom again on partition A instead of partition b only. And booted the phone from partition A.


#9

Yeah i use an original Charger


#10

Ty for ur reply :). Did u have any tip to get the best battery life on the oneplus ? It seems like OOS have the best batterylife. I flashed Pixelexperience and LineageOS last weeks on my OP. My Battery life didnt get better after i flashed thoose roms. I mean 6hours screen on isnt that Bad but it was alot better at the beginning. Did u have a good rom + a good kernel combination ?


#11

I will have to get back to u on this, stay tuned plz.


#12

damn i got linux but im not even sure if this is the right download for my situation. long story short i turn on my phone and it get stuck o" n the "bootloader is unlocked and software integrity blah blah blah like usual but its stuck there. when i fastboot to flash lock it and start again it says “Your device is corrupt. It cant be trusted and will not boot” I assume this is download should work but if not anyone kind enough to point me in the right direction would be freakin awsome.


#13

Just borrow your friend’s Win computer for a day. This is easy to do.


#14

I followed your video and it worked fine on a windows 10 laptop. Thanks. I was wondering because my laptop is currently dual booting win 7 and Linux mint will the msm tool still work. From taking a look at it it basically acts the same way it does when I try to run it on wine. Any advice?

https://drive.google.com/file/d/1-1MhgJqUGiNswoyiuxKwNSTeHqUvw0B8/view?usp=drivesdk


#15

My qualcomm cable doesn’t show up under ports in device manager but it recognizes that my phone is connected. When I try to start the MSM tool it just says “waiting for device” and can’t download anything.


#16

Hit download and it says waiting for device, connect the phone and cable. Hold vol up and power until download starts. Should work that way.


#17

Does this tool work it is in a boot loop with no recovery and the device state is locked?