How to UNBRICK OnePlus 8 or 8 Pro!

Before u do that maybe wait for the more experienced people to respond if this is the best/fastest way i am pretty new at this myself and dont have any experience with the oneplus devices.

But seeing as it is a windows thing and a new one like 11 maybe our windows pro can pitch in @gregoryaul

Hi, Your video is great. But I stopped at “Oneplus MSM tool really allow you to unbrick your phone at Qualcomm or CPU Chip level”.

So, anyone can help me out with my Query.

I have my imei number changed on my Oneplus 8 T-Mobile variant when I bought it and I also verified it by dialing *#06#. Now if I use MSM tool will it also change or reset the imei number it used to have ?

1 Like

I see no awnser so i wil show this link

Follow the how to install oracle vm install and on your left hand it shows u also how to get a os running in oracle.

Then when u have done that u need to forward the usb connection so basicly if u put a usb or connect your phone to your computer and u are running windows 10 in the vm it wil be detected in the vm. see howto below

goodluck

It sounds like USB driver issue. Maybe this will help?

Thanks for the reply, I updated the drivers and my computer now recognizes the phone but after I go through the motions and have it ready to go and click start, it says “getting android ready” and each and every time exactly at 18 seconds it says “timed out”.

Anyone got any ideas??

I do not right off hand, but I will try and research. Hopefully someone else will as well.

Post a copy what u have done in cmd in here?

I have tried looking online even tried google but cant find anything?

honestly @blueswerks he needs this in a hurry figure it would be faster to just use oracle vm.

EditL w11 is stil new

Win 11 is still beta and doubtful Oracle VM would be compatible at this point in time.

[Presently, VirtualBox runs on Windows, Linux, Macintosh, and Solaris hosts and supports a large number of guest operating systems including but not limited to Windows (NT 4.0, 2000, XP, Server 2003, Vista, Windows 7, Windows 8, Windows 10), DOS/Windows 3.x, Linux (2.4, 2.6, 3.x and 4.x), Solaris and OpenSolaris, OS/2, and OpenBSD.](https://www.virtualbox.org/)

1 Like

Hmmm how about if he runs linux distro on live usb ? is that possible or does that also need to be able to work with w11? @blueswerks

Didnt u make a back up of your stock rom before u flashed a custom rom the very first time? and if not i dont know if u can download a stockrom somewhere and just flash it (dont know if possible on oneplus) and then just leave twrp on it?

When you live boot USB, it is stand alone. The main problem, as I understand it, the OnePlus tools need a Windows environment (OS) to function. That is why I pointed to https://forums.oneplus.com/ for possible answers.

I see to bad and what if he dualboots w11 and 10 ? if his hardware capable of it? or if it is even possible ?

If the problem is Win 11, then it may.

“… XDA Recognized Developer mauronofrio has compiled and provided fastboot ROMs for the OnePlus 8 and OnePlus 8 Pro on the XDA forums. These are essentially factory images that you could flash using fastboot and easily restore the stock firmware.”

&

Hey I never realized you guys had replied.

I honestly did not make a backup as I had rooted the phone and installed the Evolution X ROM the day I got the phone as I did not want to go through setting up my phone and then shortly after having to redo it all over again.

This was my very first time rooting and installing a custom rom on a phone so I did not think that making a backup on a phone that was blank slate necessary. ( much to my regret )

So I ended up reverting back to Windows 10 and updated all the drivers but now the issue I am facing is,

When I connect the phone to computer,
Device Manager shows the Qualcom part but the MSM tool does not recognize the phone, I’ve tried the India, EUR & International versions of this tool and same thing each time…

My Model # is IN2020.

I’m completely stumped

Did you download the drivers from https://oneplususbdrivers.com/ ?

I also saw: https://www.reddit.com/r/OnePlus8Pro/comments/nga238/helpmsm_tool_not_recognizing_my_bricked_8_pro/

…“Found the solution! Will leave it here for everybody who will face the same problem. Windows 10 requires signed drivers. So when you see this triangle you have to deactivate this safety feature. Just google for Code 52. It worked immediately after I did this…”

Not sure about either as I have no way to replicate.

The other couple of links I posted July 14 do not use MSM, although one does use TWRP.

1 Like

@Asim_A try the links blues posted they seem viable goodluck.

1 Like

Greetings Max!

  1. I am having trouble loading the website above to download those files. I am currently in Malaysia and no luck of accessing the website from here even with a VPN.
    Therefore, I wonder will the package from below website works the same for the OnePlus 8 Pro?
    Link: [OP8PRO][OOS 11AA/BA/DA] Unbrick tool to restore your device to OxygenOS | XDA Forums

  2. I bought this device from China and thus running hydrogen OS out of the box. So can I still use this method with the Oxygen OS package?

Thank you in advance!

I can CONFIRM the MSM Tool works on Windows 11. Just install the QDLoader Drivers and Oneplus Drivers. Make sure Dev Tools option for USB Debugging is ON and you allow RSA connections set to ALWAYS ALLOW when you connect to a USB cable. (A Pop up will show on the screen)

—VERY IMPORTANT STEP—

MAKE SURE WIFI IS TURNED OFF WHEN YOU START THE TOOL AND UNTIL THE TOOL HAS BEGUN DOING ITS MAGIC. YOU WILL GET ALL KINDS OF ERRORS IF WIFI IS STILL ENABLED WHEN YOU START THE APPLICATION.

Then you can turn the Wifi back on and all should be good. If your internet is LAN then you do not need to worry about this.

1 Like

Hey man. Did you ever get through? I’ve tested on two PCs and they both don’t show the com ports. You need to get your PC into test mode for it to show up.