How to Run Fortnite on ANY Rooted Android!


#1

Originally published at: http://highonandroid.com/android-howtos/how-to-run-fortnite-on-any-rooted-android/

This tutorial, I am going to show you how to run Fortnite on ANY rooted Android device! While there have been many attempts to run Fornite on a rooted Android device, none of them actually work at the moment(as of 3:36PM August 10th 2018) but after reverse-engineering the Fornite app, I was able to figure…


#2

Mi5s, Custom Lineage OS 15.1
Not working


#3

Try stock firmware, I haven’t got it to work on any custom ROMs yet. Seems like Fortnite app checks for that.


#4

I was able to pass safetynet after installing magisk but after changing build.prop and then uninstalling magisk and root safetynet fails CTS profile. Have oneplus 3 edited build prop to spoof S8


#5

Hi, I changed my device build.prop to s9 and my screen turns upside down. I tried ro.sf.hwrotation with all values but no change. I use a redmi note 5 with miui stock rom


#6

It REALLY worked for me! I’m using a Mi A1 in custom liquid remix rom. Will try more roms soon but stock doesnt work since it bootloops when changing build prop.


#7

Guys if this method does not work for you, simply delete the MagiskManager folder in your storage, reboot, and voila!

Also I found out you can run other root apps along with it just fine, Fortnite app only checks for Magisk app and directory actually.


#8

I installed the latest magisk apk and already flashed the zip file .
My phone is rooted properly but there is some error in safetynet checking it shows that: THE RESPONSE IS INVALID
The reason according to me is the empty payload
I have tried the beta version as well but still the error remains same
I want to play fortnite and use some banking apps but it doesn’t allow me
I am using OnePlus 6

Any kind of help will be appreciated
Thanks!

Can someone help me out?
Please!!!


#9

Hi, I just signed up to answer. It works on OnePlus 5 Rom Stock Oreo 8.1 OOS v5.1.4 Root Magisk 16.7 beta thanks for all the work provides to more …


#10

safetynet is having some server problems, it might actually be passing but not showing. But also try using Magisk V16 as I was able to get it running with that version on my OP6 running latest OxgenOS.


#12

I’ve gotten this to work, and no longer get the message saying it won’t run because I’m rooted, but I now get kicked with a message stating that I have been disconnected due to internet lag, my ip or machine, vpn usage, or being on an untrusted platform. This appears on both wifi and cellular, and I don’t get it on my pc. Anyone know what causes it?


#13

Hi Max, thanks for the amazing tutorial. I have been tinkering with this for the past 2 days on my Project Fi Moto x4, and have twice now stumbled at the exact same point, and was wondering if you might have some idea as to how I might get unstuck.

I have successfully unlocked bootloader, installed twrp, magisk (17.1) and magisk manager. After doing this, I can verify root is enabled and safetynet check is green for both ctsProfile and basicIntegrity. I use magisk hide on google play store and google services framework (i read that somewhere, cannot recall where now though), and then begin making changes to buildprop using the same app as in your videos. i make all six changes as outlined in your tutorial (going with crownlte, hoping for that galaxy skin!), and then reboot. at this point, i recheck safetynet and ctsProfile is now FAILED. i go back into the buildprop editor and triplecheck my changes; everything is correct. i then scroll down through some more and notice some additional values that might need to be changed, so i try changing these:
ro.vendor.product.brand : motorola -> samsung
ro.vendor.product.device : payton_sprout -> crownlte
ro.vendor.product.manufacturer : motorola -> samsung
ro.vendor.product.model : moto x4 -> SM-N960F
ro.vendor.product.name : payton_fi -> crownltexx
after reboot, still fails ctsProfile. i try making one more change:
ro.hardware.sensors : payton_sprout -> crownlte
but still fails after reboot. those were all of the values that appeared similar to those changed in your tutorial, hence my trial (and error).

at this point, I was able to restore my original, unedited buildprop file and, after reboot, get ctsProfile to pass again, so that’s good at least. I’m hoping that, if nothing else, I should be able to still use Google Pay at this point (do you know?)

So do you have any idea what else I might need to try? editing the buildprop is all pretty over my head, but I think I know enough at this point to be able to roll back as needed (after two lengthy failed attempts). Would it be helpful for me to pull a copy of the full buildprop and post here?

Any help you can offer would be hugely appreciated. Thanks again!
-Brian


#14

A quick update: I successfully used Google Pay today, so undoing my changes to the buildprop file was all that was needed restore that functionality. So my main question going forward is: do you (or anyone else) have any idea why these changes to the buildprop aren’t having the desired effect? Thanks again!