How to Root Galaxy S8/S8+ on Android 9.0 Pie!


Originally published at:

In this tutorial, I am going to show you how to root the Samsung Galaxy S8 or S8 Plus on latest Android 9.0 Pie. This root method is probably the easiest method so long as you follow step-by-step. This root method supports the following models: Exynos Galaxy S8 SM-G950F, SM-G950FD, Korean SM-G950N Exynos Galaxy S8+…


Video Tutorial:


I was on oreo before and updated to pie by OTA .
After i found ur video and followed ur instructions but no luck , i failed . My problem is
Oem unlock is turned on , but i m still seeing the rmm state prenormal in download mode . Should i wait for 7 days .
Any idea please help me , thanks .
I am using SM-G955FD Exynos.


Yes wait 7 days more plz


Thz . I will be keeping in touch :v: :slight_smile: :v:


do you have a link to everything i need to download?


I downloaded my TWRP recovery file but it’s a WinRar folder… and if I unzip it I get a file that says Recovery (disc image file).

Instead, you have an actual file which you didn’t unzip or anything like that and the type of file says: ALZip tar File.

Maybe the link you provided is wrong? I’m this one btw–> Galaxy S8 SM-G950F



should n wait till my contract ends


i followed each and every step very thoroughly. but after completing the whole process as you said that if magisk app is not there . reboot to recovery and reinstall the magisk. after rebooting it says in red colour at the upper right corner “only official binaries are allowed to be installed…” and then the phone just turnoff by itself. Please help


I waited for 7 days patiently, and got the root access now . Thanks .
Hope u will be contributing more in the fiture .
:v: :slight_smile: :v:


I think the problem is Rmm state prenormal .I suggest u to flash official frameware for your device from via odin . And check in download mode if your rmm state is prenormal or not mentioned . If it is prenormal , u will have to wait for 7 days [ 168 hours ].
If it is not mentioned in download mode , u can follow each and every instructions as per video and gain root access . This procedure works for me . I am using SMG 955FD PIE .


When i try install magisk, it says:
-Unmounting Partition
Updater Process Ended With Error: 1
Error installing zip file ‘/sdcard/’
Any fix?


Got stuck at Step 16. When I rebooted my SM-G950F, the phone went into a reboot loop, with the “only official binaries are allowed to be installed” message displayed. I took it to some technician who tried to install the official Android 9 firmware, and the phone got stuck at the Samsung logo screen and I eventually force rebooted after 3 hours. Now the binaries message is gone, but phone will not turn on and can only go into download mode. State is prenormal. I will be trying to flash the official firmware myself (not an easy task with the Syrian Internet speed). Please someone answer this question: When I go to or similar, how do I know which official firmware to download? There are hundreds of country- and network-specific firmware there.
P.S. I wish some sweet soul could fix and root the phone for me online (if possible). Unfortunately, we cannot make money transfers from Syria. :pensive:


Problem solved and my G950F is rooted now. Thank you very much, Max Lee.


Dont unzip tar file. Sorry just saw this.


Your tutorial is very good and thanks for putting the link in the XDA forum.
But my problem is in FRP STATE.
After installing Android 9, TWRP, Magisk, etc. Restart the phone, and install all Google Play updates, restart again, it shows the message “only official realease binaries are allowed to be flashed” and in the download mode appears FRP STATE lock.


Is there any way to enable native call recording after root?


after root my phone samsung logo only display on dont work how to fix pleace help me


Hello max. Is it important to wipe data in step 11?


Very important, that is why it is in the tutorial. If you don’t wipe, you will end up with a brick.