How to Root Galaxy S8 or S8 Plus on Android 8.0 Oreo!


#1

Originally published at: http://galaxys8root.com/galaxy-s8-root/how-to-root-galaxy-s8-or-s8-plus-on-android-8-0-oreo/

For those of you who want to root your Samsung Galaxy S8 or S8+ on latest Android 8.0 Oreo, here’s how to do it. Before we begin, rooting process WILL ERASE EVERYTHING ON YOUR PHONE and you will LOSE SAMSUNG PAY FORVER!!!(But you can use Google Pay.) This root supports the following models: Galaxy S8…


#2

Video Tutorial here:


#3

Thanks for the guide! I’ve been using your sites since way back when I had a Galaxy SII. Really helped me get the most out of that phone. Do you have any recommendations for S8 ROMS? I love a stock feeling ROM - I’d have stuck with my Nexus 6p if it wasn’t for the battery issues and if it was a bit smaller in the hand…


#4

Try S9 ROM here: How to Install Galaxy S9 ROM on Galaxy S8/S8 Plus!

been running it for 2 weeks as daily driver, flawless.


#5

Well, works on last Firmware? (2CRED). It looks like something has changed in BL and Modem… Thanks


#6

Yes ROMs work regardless of BL and modem. BL is for bootloader.


#7

Thank you so much, bro!


#8

Hi, I followed your instruction and gained root. Magisk, Magisk Hide and all the root apps worked BUT so many of my “normal” apps kept crashing or didn’t work correctly at all. AquaMail for instance didn’t show any of my Emails. There was a message about some code error. Also TWRP showed “unable to mount storage” when I tried to wipe cash…This happened 2x now. After rooting for the first time a couple of weeks ago I was so frustrated and went back to stock. Now, last night I tried again and exactly the same problems occurred. Now, once again I am back on stock - frustrated as can be…Please Help!


#9

That is weird, never heard of anyone doing that yet? Not sure what is going on but try a fresh reinstall of stock rom then root.


#10

Hello,

Just followed this guide and everything appeared to go exactly as the video. Signed in once the phone had rebooted but it did not have magisk installed? Tried downloading titanium backup but it does not have root access.

Any idea where I might have gone wrong? This is my first attempt at rooting so apologies if I’ve made some basic error, but as far as I can tell everything went right.


#11

I tried a 3rd time but this time installed AlexisRom right away and everything works GREAT!


#12

anyone can explane me, why we dont need to install the “no-verity-opt-encrypt-5.1” zip from the xda or other instruktion.
What are here different?

regards


#13

What’s the Samfail method?


#14

SamFail method is for U.S. variants with locked bootloader


#15

Thank you for the info, but where can I find it?


#16

Google is your friend!


#17

root fail on my s8+ with august security patch build number G955FXXU3CRGH every time i reboot after complete setup HELP!!!


#18

Did you try using Magisk v16.7?

https://download.highonandroid.com/file/Tools/Magisk/Magisk-v16.7.zip.html


#19

will this root method work on SM-G9550 ?


#20

Is this running with the latest CRGH ROM?
I’m a little bit afraid about antiroot-patch script which is replacing hex into the binary kernel!
Thanks for your reply.