How to Install TWRP & Root w/ Magisk on Samsung Android! [UNIVERSAL METHOD]


I tried 3 times to root my new galaxy S8 and I’m stucked at the samsung starting message with on top of screen in red “Only official ROM are allowed to be flashed”.

I have:

  • new one SM-G950FD bought end of august 2018
  • ROM G950FXXU3CRGH from sammobile, august 2018

I have tried to install using Odin3-v3.13.1 started as administrator:

  • twrp-3.2.3-0-dreamlte.img.tar from

The format displayed an error after “Formatting Data using make_ext4fs”: Cannot umount /data (probably because TWRP was there) but was displayed cleaned on my PC.

At end, when we have to reboot, I don’t know if I have to use “Reboot System” or “System” into the reboot menu and if we have to choose “Do Not Install”

Anyway, Magisk Manager said that magisk is not installed and I have read somewhere that we have to simply reboot once. I’ve also got a popup about “some operations have to be done by rebooting” (I don’t remember exactly the message and it’s in French of cause, sorry!!!) and at reboot I’m stucked with the message “Only official ROM are… and so on”

So, what is running wrong, is the issue coming from the new hardware or the new ROM or my process understanding?

Thanks for your support!!


Yeah Samsung has started blocking root so you have to install TWRP then flash a custom ROM right after. I am currently NOT trying to replicate the process since I would lose root for next 7 days but I may do an updated tutorial showing how to install a custom ROM instead of rooting.


Hello! I followed your tutorial and successfully installed TWRP and rooted with Magisk on my Galaxy S9 (G9600 - Snapdragon), but whenever I reboot the phone locks with the unauthorized software error and I have to flash the stock ROM again to unlock it. Do you think that flashing a custom ROM would solve it? Thank you very much.


Yes you can refresh stock firmware in that mode. Next time try installing a custom ROM as Samsung has put more blocks. I will be posting a solution shortly also.


Thanks a lot! After the next seven days jail cycle I’ll try to flash a custom ROM and let you know the result.


Hi Max - I’m getting conflicting info as to if I can ROOT (no custom Rom) my Canadian SM-G950W Oreo 8.0 on Snapdragon. I have no OEM Unlock option but I have also read some Samsung models don’t display the option despite having an unlocked bootloader. Please halp


You should see the option. If you have Snapdragon model it probably has locked bootloader though.


I had Note 8 SM-9500 snapdragon Chinese version
I couldn’t find the OEM Unlock option, note that i had enabled the developer mode long back
Is that means i can not use this method and can not unloack my phone
I bough this version because of its storage and i noticed from my older samsung devices that only snapdragon devices can be unlocked
Its look like this has bean changed ;(


Boot into download mode and see if it says oem unlock enabled or not. If it doesn’t exist you have unlocked bootloader.


Hello, I followed your guide step by step and successfully installed TWRP and rooted with Magisk on my Galaxy S8+ (G955FD). When I restarted the phone I ended up stuck on a bootloop with the message “Only official released binaries are allowed to be flashed”. Means I can’t use recovery through TWRP to flash stock firmware. I then went into Odin to try and flash the stock firmware but it always "FAIL"s. Note: When I try to flash stock firmware the problem occuring in ODIN log is “sboot.bin”. Is this a problem with the bootloader? What suggested step would you have for me?


You need to use latest Odin here


In download mode this is what i get:
RPMB fuse blown
CURRENT BINARY : Samsung Official
RP SWEV : B4(2,1,1,1,1) K1 S1
DID : did_number


Thank you for the detailed tutorial.
I am getting into an error when trying to install either of the zip files:

Checking for Digest file
Skipping Digest check: no Digest file found
Zip file is corrupt!
Error installing zip file

What am I doing wrong?

Thank you


maybe bad file? Double check zip file is good by opening it up, if it doesn’t open then it is a bad file.


I worked around this problem by using the adb sideload feature in TWRP, and installing the zip files from the computer (command prompt).

I was able to get root! (Thank you)

However, now I’m encountering a weird problem.
My phone keeps freezing when the screen goes off.:frowning:
I have to force reboot it every time. This, obviously, renders the phone useless.
Not sure what exactly causes that.
Do you have any idea?

Thanks again for the awesome tutorial and for responding.

Edit: I tried wiping cache and dalvik, but that did not help.


Dear Max,
I have three questions:

  1. After Step 7 you said, one could install a custom ROM, could we also reboot without doing anything else and use the stock samsung Firmware, or would that cause a bootloop?
  2. Could I just install no-verity-… and RMM-State_… without Root and use the stock samsung firmware? Would it be possible to still get OTA updates with this configuration?
  3. Could I flash a new Custom ROM, after I installed no-verity-… and RMM-State_…? So that I could first make a nandroid backup of configuration 2 and afterwards install lineageOS? When yes, should I wipe first (factory reset) or should I also reformat?

I am a total newbie and would be happy over any information, thanks a lot!


Hi. I followed every step on your YouTube video to root my Galaxy S9+ star1lte. I installed the twrp using odin, I used the no verity zip and I made sure to use the magisk version on your website thats specifically for s9+. (v16.3 i think) I did everything in the video but when I try to boot into system, I get stuck on the booting screen. I tried to go back into twrp and flash the magisk uninstaller, in case i was stuck in a bootloop. The uninstaller refused to flash, giving me an error.

What should I do to fix this?


Hello! I have a problem with the root of my Samsung s5 … I do everything you do in the video, but when I want to install the “Magisk” program it always gives me this error "error installing zip '/ sdcard / magisk-v16 "
what could I do? thank you so much! and sorry for my english :slight_smile:


Double check you have the zip file is not corrupt, copy the file to your computer and try to open it, if you can’t redownload the file.


Thank you for your reply!

the file should not be corrupted, because besides that I have also tried other or other versions “magisk 16 or magisk 18”, but the error is always … another solution? please