How to Install GSI ROM on Pixel 2 & Pixel 2 XL!

the sound selector and android 9 and 10 navigation gestures seems to be buggy!! any fix?

What phone are you using?

HI Max. Question I gotten Havoc rom installed working great. Now ive tried a few more rom such as Evolution X , Corvus, LineageOS and RR and they all boot but when i get to the adb command boot in twrp they all just hangup at splash screen any ideas on how to get twrp to boot to fix partions ?

You can use fastboot to resize partition

Hi Max … thanks for fast respond …okay now How ? what the adb command ?

1 Like

hi greg here u can look up adb commands on google if your still having trouble than ask kk, i still dont know them all either i have to look them up sometimes too

Pixel 2… actually now the gestures are fine and I installed the pixel sounds app which is also fine now…the issues currently which exists are no active edge support and I’m unable to turn on hey google.

and in the ringtones section its showing like this…can this changed back to how it was on stock? Any help for these would be nice…:slight_smile: Great job on the tutorial btw!

2 Likes

It depends on the rom and kernel if it’s supported or not if the devs update the rom ur on then maybe so u could check for a update

how do I root this rom? I booted twrp and flashed magisk but ctsprofile is false.U said to root using the boot img but there’s no boot img either

how do I update?

1 Like

Just wait for the newest version and reflash the gsi with the auto flasher and delete the fastboot-w command line in the scriptor add three dots in front of fastboot-w

https://forum.highonandroid.com/t/auto-gsi-installer-for-pixel-3-3-xl-3a-3a-xl-4-4-xl-and-4a/231/2

thats not for pixel 2… to update just repeat without wiping.

Skip

fastboot -w

1 Like

Hello is there a guide to root s7 sm g930t or any guide for this model? Please respond

Please see: https://galaxys7root.com/

HI guys anyone able to get any other GSI rom working on Pixel 2 XL other than Havoc ?

Why all the GSI rom for Pixel 2 XL on step 7 get stuck on TWRP boot screen any fix for that ? … Iv tried everything I could Help Please. Thanks

Which GSI are you trying to install? Also make sure you are on Android 10 firmware.

Morning Max yes im on android 10 okay Ive figured it out dirty flash without adb command -w . Now my google play service keep crashing anyway to fix that ? Ive installed the crdrom its awesome but now my google play store keep crashing keep getting google service stop app pop up ?

1 Like

Oh if it boots well just do a regular factory reset, regular wipe in twrp. It should work.

1 Like

I also have this issue, on pixel 2 XL, did you get it fixed?