How to Install Carbon ROM for OnePlus 8 Pro!

Here’s how to install Carbon ROM for your OnePlus 8 Pro!

Video Tutorial:

Step 1. You will need to unlock the bootloader first, follow my universal guide here:

Note: If you are using a carrier-branded OnePlus 8 Pro such as T-Mobile or Verizon, you will have to unlock the bootloader by getting unlocked code from your carrier, you can search on Google on how to do this. But next time, simply buy the unlocked model as it supports full 4G LTE/5G bands on T-Mobile or Verizon, you don’t gain ANYTHING by buying T-Mobile/Verizon models, you actually lose dual SIM capability and another process to unlock the bootloader.

You just need to unlock the bootloader, you do NOT need to follow the root guide as we are simply installing a custom ROM.

Step 2. You will need to flash TWRP recovery.

Download fastboot.zip:
https://download.highonandroid.com/file/Tools/fastboot.zip.html

Unzip fastboot.zip and you should find a new folder called “fastboot”.

Step 3. Download TWRP and userdata image for OnePlus 8 Pro:

Download TWRP:
https://download.highonandroid.com/file/TWRP/OnePlus8Plus/beta/twrp-3.4.0-2-instantnoodle-unified-mauronofrio.img.html

Download userdata.img:
https://download.highonandroid.com/file/ROMs/OnePlus8Pro/CarbonROM/userdata.img.html

Copy BOTH of these files into the fastboot folder.

Step 4. Open a command prompt by typing “cmd” after pressing the Windows Start button.

cd Downloads
cd fastboot
fastboot flash recovery_a twrp-3.4.0-2-instantnoodle-unified-mauronofrio.img
fastboot flash recovery_b twrp-3.4.0-2-instantnoodle-unified-mauronofrio.img

Step 5. This next command WILL ERASE EVERYTHING on your OnePlus 8 Pro! You NEED TO WIPE DATA in order to install this ROM or any custom ROM. If you have to backup anything, STOP at this step, reboot your phone and BACKUP EVERYTHING you need to backup then come back to this step.

Next type the following and hit Enter:

fastboot flash userdata userdata.img

That will flash the recovery to both slot A and B so you can access TWRP from now on without having to reflash. If you ever lose TWRP recovery, you can go ahead and repeat Steps 2-3 to re-install your TWRP recovery which can sometimes happen after installing a ROM.

Step 6. DO NOT REBOOT. Use the Volume keys to find “RECOVERY” then hit the power button.

Step 7. Download ROM and Gapps, copy over to your phone while in TWRP recovery mode. If for some reason your phone does not connect as disk drive(as sometimes happens with Windows, follow this guide).

Download ROM:
https://download.highonandroid.com/file/ROMs/OnePlus8Pro/CarbonROM/CARBON-CR-8.0-PAX-UNOFFICIAL-instantnoodlep-20200906-0207.zip

Download Gapps: (Grab arm64, Android 10.0, pico)
https://opengapps.org/

Step 8. Once in TWRP recovery, go ahead and flash the ROM and Gapps. If you want root, also flash Magisk.

Step 9. Reboot and profit! You should now be on Carbon ROM. Enjoy!

I usually leave the version I used in my tutorial because with updates sometimes things can become different or even break. I usually stick with which ever version I flash and only update major updates.

If you want the latest version and you are reading this tutorial in the way future, you can check out the XDA thread where the ROM is posted:

If you need camera, install the Google Camera:

For OnePlus camera, I am still trying to figure out to make it fully.

Overview of the ROM here:

2 Likes

does it usually take for ever for the first boot up , also i got an error using pico gapps, but switching to nano worked

2 Likes

Nice good job

1 Like

did you get it to work

2 Likes

I don’t own a op8pro but I was just saying good job for figuring it out​:grin::grin:

1 Like

Yeah there’s a bug on openapps, sometimes you get bad files because it creates files on the go. Today it took me hours to figure it out.

1 Like

i have been stuck trying to get this carbon rom to work

1 Like

now when i install the rom and the gapps i just get loaded straight back to twrp

1 Like

Make sure u flash the user data image file that erases everything as twrp is broke still for data wipe

1 Like

Can you update tutorial on flashing rom with twrp installer I think with the new twrp you don’t need a computer

2 Likes

Sure will do!

1 Like

If I’m on android 11 oxygen os can I still install this or do I need to switch back to 10

1 Like

So I tried so many times I’m on global firmware I can install twrp just fine but for some reason when it comes to flashing roms it puts me back into twrp and stuck in one slot or other times I get stuck on crash dump and have to restart I’m using latest twrp recovery I eventually gave up and went back to his and just installed magisk on 10.5.13

1 Like

I also tried many times but doesn’t seem to work ,I’m on 10.5.12 and followed all the steps and flashed user data image but it will be in bootloop with carbon rom logo .

2 Likes

Did u follow the flash instructions on the carbon rom thread??

1 Like

Send me the thread u used please

1 Like

I use Max’s video as a guide ,after you said it I checked the xda thread and the only thing that I didn’t do is reboot recovery(to switch between slots)

2 Likes
1 Like

That can make or break it

1 Like

You definitely need to reboot to recovery and swap slots.

2 Likes