How to Install Android 9.0 Pie w/ Root on OnePlus One!


#1

Originally published at: http://highonandroid.com/android-roms/how-to-install-android-9-0-pie-w-root-on-oneplus-one/

For those of you who have a OnePlus One, Android 9.0 Pie is now available through a custom ROM called PSOP(Potato Open Sauce Project). Now, this ROM has pretty much everything working out of the box including voice calls, 4G LTE, Bluetooth, NFC, etc…etc… Developer says GPS is a bit wonky but seems to work…


#2

Speech to text doesn’t work. Wonder if it is the Pixel launcher?


#3

I couldn’t find a way to disable hardware/software navigation keys. So right now, both of them are active.


#4

I also have the same problem. Please help me to disable on screen navigation buttons.


#5

Same problem too, both the capacitive buttons and the on screen ones are enable.
I also have two little issues:
-In the P launcher I can’t get the “Show Google App” to work in the home settings, even if enabled nothing
changes
-I can’t get “swipe up on home button” working properly, I can’t use “double swipe” up to get to the drawer
Anyway this guide is very good, thanks.


#6

Hey Max, installing Android 9.0 Pie worked perfect, on one exception. I am unable to transfer data to my computer when I connect the phone using a USB cable. The dots below ‘USB controlled by’ and ’ Use USB for’ are all grayed out. Do you have an explanation and/or fix for that? I am using Windows 10 and if does find the phone (like before the update). Is seems it is using the latest driver. Enabling dev. mode and disabling dev. mode does noting. Thanks, Q.


#7

i am getting an error 7 while installing gapps… how to rectify it… confused i am


#8

Damn that’s weird, trying to figure it out. You can use AirDroid for the time being:
https://highonandroid.com/android-apps/app-of-the-week-airdroid-connect-your-android-via-wifi-to-your-computer-instantly/


#9

Which Gapps are you using? Try this one:
https://download.downloadgapps.com/file/Gapps/9.0/open_gapps-arm-9.0-pico-20180820-UNOFFICIAL.zip.html


#10

Hi, tried to install Android 9.0 on OnePlus with Cynogen. Unlocked bootloader, flashed a new TWRP recovery, then i tried to flash Rom with the potato_bacon-9 got “Updateprocess ended with ERROR:7” and the message 'assert failed: oppo.verify_trustzone(“TZ.BF.2.0-2.0.0123”,“TZ.BF.2.0-2.0.0134”) == “1” '. Then the Gapps pkg also did not install, eror code 20, sayingthe gapps is for android 9.0.x and that the correct version for my Rom is 6.0.1.
Had to admit, it was some tough sledding getting up to speed on unlocking bootloaders, fastboot, adb, TRWP, etc and perhaps I erred somewhere along the line. In particular, my bootloader seemed to be already unlocked and my phone did not reset to factory after the fastboot oem unlock command.
Any ideas where I may have gone wrong?


#11

Seems like you are on older firmware, try updating OnePlus One to the latest firmware and try again.


#12

Hi Max,

Just following the instructions in article and video was pushing the limits of my understanding of Android.

Not sure i understand how firmware relates to a new custom Rom. Is the firmware a subset of the custom rom, or a different thing altogether? That is , if by eliminating the assert metadata checking, would that install the new custom rom and also update the firmware if it was a subset of the custom Rom? Or would it perhaps forever hard brick my phone?

Currently have bootloader unlocked and TWRP flashed to the recovery partition, as well as Magisk.zip, gapps zip, and potato_bacon-9 zip on /sdcard/Download. My original Cynogen Rom is gone, can no longer boot phone in normal system mode.

Also, having trouble getting TRWP to read contents of my USB-OTG. Perhaps its my cable. I formatted the thumbdrive as FAT32 and downloaded an edited version of the custom Rom without the asserts in the Metadata on it, thinking perhaps this would get around the error 7. However, TWRP does not show any files on on the usb-otg.

So I am wondering what and where is the latest OnePlus firmware update, and how do I flash it. At some point OnePlus moved from Cynogen to Oxygen. The one thing i know is my phone came with Cynogen. And with my current impass with USB-OTG, not sure how I would be able to get the firmware file for TRWP to install. I can not download it to my phone’s internal storage as it is bricked.

In a word, help


#13

Hi Max,

An improvement: I changed thumb drives and now TWRP can see the files on the usb-otg.


#14

You can find latest firmrware here:

Usually most TWRP will read exFat or Fat32, you may have formatted in another format or the TWRP doesn’t read exFat.


#15

Okay, i have installed that and not surprisingly receive Error 7 again, this time with the message 'This package is for “OnePlus” devices; this is a “A0001”.


#16

perhaps i would have better luck with:

Android 8.1 Oreo based OFFICIAL LineageOS 15.1 for OnePlus One (bacon) is now available to download on the OFFICIAL LineageOS website. This is a step by step guide that explains how to install the Official OnePlus One Lineage OS 15.1 ROM.


#17

Yeah it is the same model, you can either update your twrp or just get rid of the first like using http://highonandroid.com/android-roms/how-to-fix-status-7-error-with-cwm-recovery-on-rooted-android/


#18

Max,

After wandering around in the wilderness for 20 years, Moses spots the promised land. I decided to go with the Lineage OS 15.1 release as this is the legacy Cyanogen stuff carried forward. It went straight on during TWRP install either because of this or because there was no assert checking. I believe I saw a line in the log saying it was going to unconditionally apply the install. Then got an error code installing intel instead of lineageos arm gapps, and another error code 70 installing the lineageos standard arm android 8.1 gapps (no space). Finally installed the arm 32bit, android 8.1 gapps pico size (120mb versus 600mb for standard size). It went straight on, rebooted to system and I was good.

Thanks for your help, and your excellent High On Android articles and Youtube videoes for rapidly expanding my Android knowledge.


#19

Alrighty great to hear!