Help with Note 9 SM-N960F/DS Root


#1

Hi there. I am having some serious issues. Let me preface this with stating clearly that I am a complete noob when it comes to rooting. This is the first time I’ve ever tried to root.

I have a Exynos Note 9 model SM-N960F/DS. I live in the US. I have a working T-mobile sim (still works in my old phone).

Out of the box I took my old sim and put it in the phone and was able to make and receive calls, text messages, if I walked out of the house for better signal. However, I did not see any settings for Wifi calling (searched the settings area) and confirmed based on my research it would never work stock. Hence my decision to root.

It’s a little hard to retrace my steps but I will try to let you know where I stand now.

I bought the phone on eBay unlocked. In my area the cell signal is terrible and I am dependent on TMO WiFi Calling at home (I can use Skype for outbound but I hardly ever get inbound calls without it).

In order to get Wifi working I found a link for TekHD’s Detonator flash for the Note 9 (specifically to enable features like Wifi calling, etc.) here:

http://tekhd.com/detonator/#readmedetonator

I rooted (so I thought) the phone using this guide (before I found your video) and it seemed like it was sort of working. Root checker (the app) showed that root access was working. I installed the Detonator flash (copied it to the sd card, installed it using TWRP\ making sure to be in read-only mode).

When I booted the phone all seemed ok - I got the T-mobile splash screen, OS loaded, but then I noticed my IMEI information disappeared and therefore my sim was not working. I also noticed that Titanium backup did NOT work and failed to obtain root access.

Fast forward a little bit I tried reloading a stock ROM from LUX using a rom I downloaded with Sam Firm. I picked that rom based on a post on xda-developers forum but I can’t find the link atm. Anyways I punched in SM-N960F for Model and region I input LUX. I was confused by Tekhd’s instructions and thought I had to reinstall an international ROM.

When I reinstalled this using Odin, my imei information came back automatically but then the t-mobile splash screen, etc. all disappeared and the most troubling part is when I inserted my sim card I got an error saying
“Network pin blocked. Enter sim network PUK” the minute the OS loaded. The IMEI informatio was correct as I compared it to the sticker on the phone.

Somehow I managed to get it into a boot loop but managed to get out of it by going into download mode, reinstall the stock LUX rom, and now I’m back in the OS with no sim card and no connectivity but correct IMEI.

Now, if I try to go into download mode and root the phone again following your video, after using TWRP to install the N9_S9_Root_for_OEM_issue_devices_V5.zip, when I reboot it just goes into a boot loop. I see the Samsung Note 9 splash screen, then it will vibrate and reboot continuously in a loop.

Developers options is ON, OEM unlcok is ON and says Bootloader is already unlocked, and USB Debuggin is ON. The only way for me to get out of the boot loop is to quickly get into Download mode and reinstall the stock rom.

In Download mode I did notice it says “Warranty Void: 1”.

I tried at some point to make a backup using TWRP of everything (which failed on data) so I tried again with data unselected.

I think I need to be able to backup the /efs/imei directory but it is showing empty when using Terminal in TWRP.

Any help is greatly appreciated. Thank you in advance.


#2

Update:

I realized I downloaded v5 of the N9_S9_Root file…so I downloaded v3 from your site and am back into the OS!

However, I am still seeing no IMEI information, Baseband Version is also unknown.

When I check Magisk it looks good. When I ran Titanium Backup I got this message:

Error Sorry, I could not acquire root privileges. This application will not work! Please very that your rom is rooted, and try again. This attempt was made using the “su” command."


#3

I downloaded “Terminal Emulator for Android” and confirmed that the “su” command works. I uninstalled Titanium Backup and reinstalled it from the PlayStore and now when I try to open TB it just crashes immediately and says “Titanium Backup has stopped.” Send feedback".

Also downloaded “ES File Explorer File Manager” and saw that the /efs/ folder is completely empty.


#4

Another update: I somehow made some progress. I was able to find a stock samsung rom for the N960F/DS for europe. I was able to re-root it and install ES File Explorer and Terminal Emulator in order to back up the EFS/ directory (efs/imei). I was able to install the Detonator flash and surprisingly (because of the stock ROM instead of the LUX ROM) I did not lose my imei information when the phone booted up.

Now, however, I am getting this error:

“Network Lock: This device can be remotely unlocked if eligible.
Please use the “Device Unlock” application to unlock the device.
Make sure the device has an internet connectivity to use the “Device Unlock application”.”

So just to reiterate - this phone was purchased unlocked,brand new from eBay. Somehow (I’m thinking because I installed the incorrect LUX ROM) it got locked. T-mobile won’t unlock a phone that wasn’t purchased from T-mobile. I tried putting a spare blank SIM card into the note and got the same message. I feel like I’m super close to the solution…but I’m befuddled as to how to request an unlock for a phone that was never locked by a specific carrier in the first place. I have no idea what the country of origin is.

Should I use a sim unlock service? I don’t have a sim card from another carrier to use. This phone was never locked to a specific carrier that I know of…and it was working yesterday and now today it’s blocked.

Any help is greatly appreciated.


#5

Hey there, did you ever figure this out?

I ended up doing the same thing when I installed their rom and now I’m getting the same sim error on my N960F/DS.

I’m on T-Mobile too :confused: