Galaxy S3 unroot failed

I rooted my phone a few years back using the instructions here:

I just tried to unroot using the “Full Unroot” option in the SuperSU app. Seemed to go all right, but after reboot, it’s apparently still rooted.

Would be grateful for ANY suggestions on how to resolve this.


If you do a full back up if needed if you factory rest should take care of that and or format data

1 Like

Thanks, but that’s exactly what I was trying to avoid. The only way I know of to save copies (and not even restore) all SMS and MMS is some software that saves it in PDF format on PC. And even that requires an Android update to at least 5.0. I only have KitKat 4.4.2 which of course I CAN’T update unless I can fully unroot. So I’m stuck in a circle. :slightly_frowning_face:

1 Like

What about Google Messages “2.9.050”? If it’s like the current version, it backs up your SMS and MMS to your Google Drive. If you do some web searching, you will find several places to download the old version 2.9.050 APK which is compatible with Android™ 4.4, KitKat, and above. Unless Google has blocked the old version in the same manner as Google Inbox. It’s only around 17mb to download and try it.

Thanks, I’ll check it out!

1 Like

This will handle backing up your texts, MMS and phone calls. It saves them in a way that when you restore the backup it puts everything back in the conversation threads and call logs just how they were. This is by far the easiest way to back that stuff up.

1 Like

I’ve been using that since my old Galaxy S3 days, but I hesitated to recommend because I was not sure if it is still compatible with 4.4.2. It is very nice program:)

1 Like

Uhh … not a fan of that app. Tried it a couple years ago. It stated that one could back up everything to a Gmail account. I tried that and apparently all my SMS and MMS messages ended up in the cyberspace bitbucket. They never arrived in my Gmail account. I checked EVERYTHING and I definitely had all the right settings … but my messages just disappeared.

Hmm, I’ve never had that issue with the app, it’s just always works for me. It’s what I always use when I’m setting up a new phone for someone. I do also make a local backup though. Are you sure you checked the right place for the backup? It doesn’t go to your Gmail, it goes to Google Drive if that’s how you have it set.

1 Like

I had it set for Gmail. (I’ve only got 75MB of files on G.Drive, and nothing in the trash.)

Correction … I didn’t actually set it. The app TOLD me it was going to Gmail.

I’ll download it again and make another attempt if I have time later.
Thanks for the info.

That’s really odd that it said it was automatically going to your Gmail. That has to actually be turned on in the settings, and I believe it’s a secondary backup. There’s four save locations you can pick from. They are Google Drive, Dropbox, OneDrive or make a Local Backup on the actual device. I’m betting what might’ve happened is you didn’t choose one of those options for the backup location, so it didn’t actually save the backup at all there wasn’t anything to send to your Gmail. Just make sure if you do try the app, go into the settings and pick a save location before you run any backups. :slightly_smiling_face:

1 Like