Closed Sony xz1 compact driver problem?

Oke so i finally got araund to do my daily driver sony xz1 compact and when i tried to unlock the bootloader using flashtool also know as sony mobile flasher by androyxde.

I get the following error

ERROR - Cannot invoke “String.split(String)” because the return value of “java.util.Properties.getProperty(String)” is null

now i looked everywhere on the internet literally and i could not find a awnser to my problem but i did find multible people with this problem but no awnser…

but i kept looking and i found that my computer can not find my phone exactlly because when i use command and try adb devices it cant see it but fastboot mode it can.
so i looked for an awnser and said probally need to update your drivers so i downloaded drivers from the sony site installed them then got the message that i have to restart computer before it can go into effect and i do that and then nothing stil does not work i see no adb devices in the list

oh and i selected the allow unknow drivers from the security option in windos 10 so that should be oke

I think this might be the problem that adb devices cant be read seeing as it has to be in that mode when trying to unlock the bootloader in flashtool.

please help because i spent the entire saturday doing this driving me crazy

Edit:this is what it shows in the program

01/048/2021 22:48:26 - INFO - Flashtool 0.9.33.0
01/048/2021 22:48:26 - INFO - Searching for a web proxy
01/048/2021 22:48:26 - INFO - No proxy found, using direct connection
01/048/2021 22:48:27 - INFO - Syncing devices from github
01/048/2021 22:48:27 - INFO - Opening devices repository.
01/048/2021 22:48:28 - INFO - Scanning devices folder for changes.
01/048/2021 22:48:36 - INFO - Pulling changes from github.
01/048/2021 22:48:37 - INFO - Devices sync finished.
01/048/2021 22:48:39 - INFO - Loading devices database
01/048/2021 22:48:39 - INFO - Loaded 131 devices
01/048/2021 22:48:39 - INFO - Starting phone detection
01/048/2021 22:48:58 - INFO - Device connected with USB debugging on
01/049/2021 22:49:01 - INFO - Connected device : Sony Xperia XZ1 Compact
01/049/2021 22:49:01 - INFO - Installed version of busybox : N/A
01/049/2021 22:49:01 - INFO - Android version : 9 / kernel version : 4.4.148-perf+ / Platform : 64bits / Build number : 47.2.A.11.228
01/049/2021 22:49:01 - INFO - Root access denied

after that i try ubl option

01/051/2021 22:51:20 - INFO - Please connect your device into flashmode.
01/051/2021 22:51:57 - INFO - Using Gordon gate drivers version 3.2.0.0
01/051/2021 22:51:58 - INFO - Opening device for R/W
01/051/2021 22:51:58 - INFO - Device ready for R/W.
01/051/2021 22:51:58 - INFO - Reading device information
01/051/2021 22:51:58 - INFO - Reading phone properties
01/051/2021 22:51:58 - INFO - Sending getvar:product
01/051/2021 22:51:58 - INFO - getvar status : OKAY
01/051/2021 22:51:58 - INFO - Sending Read-TA:2:2202
01/051/2021 22:51:58 - INFO - Read-TA status : OKAY
01/051/2021 22:51:58 - INFO - Sending Read-TA:2:2205
01/051/2021 22:51:58 - INFO - Read-TA status : OKAY
01/051/2021 22:51:58 - INFO - Sending Read-TA:2:2210
01/051/2021 22:51:58 - INFO - Read-TA status : OKAY
01/051/2021 22:51:58 - INFO - Sending Read-TA:2:4900
01/051/2021 22:51:58 - INFO - Read-TA status : OKAY
01/051/2021 22:51:58 - INFO - Sending Read-TA:2:10021
01/051/2021 22:51:58 - INFO - Read-TA status : OKAY
01/051/2021 22:51:58 - INFO - Sending Get-root-key-hash
01/051/2021 22:51:58 - INFO - Get-root-key-hash status : OKAY
01/051/2021 22:51:59 - INFO - Connected device : G8441 / SW release 1307-7511_47.2.A.11.228 / Customization 1310-8075_R4C
01/051/2021 22:51:59 - INFO - Last flash date : 2018-11-19 23:19:03
01/051/2021 22:51:59 - INFO - Phone ready for flashmode operations.
01/051/2021 22:51:59 - ERROR - Cannot invoke “String.split(String)” because the return value of “java.util.Properties.getProperty(String)” is null

C:\Users\n>adb devices
List of devices attached
adb server is out of date. killing…

  • daemon started successfully *

C:\Users\n>adb reboot bootloader
error: device ‘(null)’ not found

C:\Users\n>

1 Like

© Microsoft Corporation. All rights reserved.

C:\Users\n>adb devices
List of devices attached

C:\Users\n>adb reboot bootloader
error: no devices/emulators found

C:\Users\n>

1 Like

I found a couple of links you may or may not have seen. The 2nd is interesting.

https://visualgdb.com/adbfix/

1 Like

Thank you for your fast reply

What is so interesting about the second link ?

i already use that program i used first on a older sony and worked wel but not now because for some reason adb/fastboot cant see my phone i do have 15 seconds adb intaller installed?

1 Like

“Thanks, I eventually figured out that I did not need to root.” :confounded:

Not any easy answers to your dilemma, unfortunately.

1 Like

Weird right that there is so little info about this what the heck is going on ??

@gregoryaul maybe an idea ?

2 Likes

Do u have usb debugging on and usb config set to file transfer??

1 Like

Also did u get the always slow from this pc window

1 Like

gregory i think i see the problem possiblely

when i put phone in fastboot mode it has seemingly the right driver as i can see it in device manager without a !

so i think that is good

2 having the phone on and it is detected as sony so that is good i think

3 the problem is here

android devices
android adb interface and it has a ! nothing i try works i keep getting a code 10 ?

looked it up and found one how to that says to delete some things ? but they also claimed it to be dangerous said i should delete these things

See screenshots below

Screenshot_1 Screenshot_2 Screenshot_3 Screenshot_4 Screenshot_5

Just realized something does it matter if usb debugging was on or of ?

Edit: oke so apperntly u can delete them and i deleted the ! one and then i reinstalled them every single one of them in that list i tried wich got rid of error code 10 nomore ! symbol if installed claims device works but none works wtf?

1 Like

I fucked up i had it … it worked i dont know what i did but it worked so i go back to flashtool thinking to get this over with now suddenlly i get error missing driver? and that i should go to the driver folder and i go there and install al of them just in case i then try it again but now i get the same error i had in the beginning ? also adb doesnt work anymore and now i try to install adb driver but it wont work ??? damn 2 steps front 3 steps back

Edit:i have lost what you can see in screenshot 3 and 4 stil cant get it back to work i followed this random howto and said something about if u get code 10 u gotta delete devices and drivers and the first time that worked because after selected adb and it worked but now if i try that everythign gone in that lsit u see in screenshot 3 and 4

I followed this one

1 Like

Heres some screenshots from how it looks like now i am so close i know it i just dont what i am doing

Screenshot_01 Screenshot_02 Screenshot_03 Screenshot_04

Screenshot_06 Screenshot_08

1 Like

Screenshot_1

When selecting driver details so that is something i alreayd knew but what am i missing here ? i could really use your help right about now @gregoryaul

i am pulling my hair out here you know how valueble that is to a man my age(32) ahahahaha

Screenshot_2

Also i like to ad that when trying to forget the device there was this box tha said erase drivers and i slected that to thats where i fucked up…

2 Likes

R you use universal adb drivers??

1 Like
1 Like

Try these go to update drivers then browse my PC then let me pic then chose universal adb drivers

I already had this one so what now ?

Also u say choose universal adb drivers but does it make a map somewhere ?? cant find anything?

1 Like

When u update drivers u should go to let me pic from PC then go to downloads and look for universal adb drivers

Go to update driver and device manager and click on forget for uninstall device you need to have a window that says allow from this PC always allow from this PC if you don’t get that window you’re always going to get an unauthorized or you know it’s not going to work right so double check that all you do is you uninstall the uninstall the device from your computer through control panel device manager and then when you plug your phone back in it should beep it should make a noise and then stuff and on your home screen you should get a little window this is always allowed from this PC or this device or whatever and then you click always

I found the folder see below for pci how it looks like.

Screenshot2 Screenshot3 Screenshot5

1 Like

U should choose android adb interface