A cry for help from a numpty with an S7 Galaxy

Hello,

I’m new to HighOnAndroid, new to Android phones in general, and I’m just about tech-savvy enough to be dangerous.

I want to load TWRP, root my phone, and load the Lineage 17.1 (stable) custom Rom on my stock Samsung Galaxy S7 (SM-G930F).

Having spent a few days trawling the web, I stumbled upon Max’s really excellent v-logs, which seemed as if he might have created them with someone like me in mind.

Now to the problem:

Despite evidence to the contrary I am absolutely convinced I have followed Max’s instructions to the letter…

First I did this: How to Install TWRP & Root w/ Magisk on Samsung Android! [UNIVERSAL METHOD] [Android Root 101 #2] | HighOnAndroid.com

Using the links provided I downloaded:

  • Odin3_v3.13.1
  • twrp-3.5.2_9-0-herolte.img.tar
  • no-verity-opt-encrypt-6.0.zip
  • Magisk-uninstaller-20180429.zip
  • Magisk-v19.3.zip
  • SAMSUNG_USB_Driver_for_Mobile_Phones.exe

I used Odin to install the TWRP tar ball (The Samsung USB Drivers were not required)
Booted into TWRP on the phone
Attempted a backup to the SD card TWRP reported it could not mount /Data and the back-up failed, so I found a fix on the XDA forum which involved formatting /Data as ext4 and then reformatting it back to its original ext2 which then allowed TWRP to mount /Data and I completed a backup
I copied the other files across on to the phone’s SD card
used TWRP to install no-verity-opt-encrypt-6.0.zip
rebooted into recovery and the “read only” warning screen had disappeared
Performed a full Wipe (Swipe to confirm)
Wiped the Dalvik / ART Cache and the Cache using “Advanced Wipe”
used TWRP to install Magisk-v19.3.zip
rebooted the system and verified the Magist app was on the phone

Obtained LineageOS and GApps from here:

These were the two files downloaded:

  • lineage-17.1-20210409-UNOFFICIAL-herolte.zip
  • open_gapps-arm64-10.0-stock-20210428.zip

Copied these files over to the SD Card
Rebooted the phone into TWRP
Used TWRP to install lineage-17.1-20210409-UNOFFICIAL-herolte.zip then (before restart)
Used TWRP to install open_gapps-arm64-10.0-stock-20210428.zip
Rebooted the phone

…and this is where it all goes wrong.

Instead of booting into the anticipated Android LinageOS 17.1 what I get is:
The Samsung Galaxy Logo
Then a blank screen
Then a light-blue curved line (like a sad mouth) is drawn right to left,
and then a small dot appears on the right of the “mouth” which travels along the arc of the “mouth” from left to right whilst growing into a circle.
The arc and the circle disappear and the cycle repeats (with the arc being drawn in a different part of the screen.

This continues for about 5 minutes. Then the phone restarts and boots into TWRP recovery.

Clearly, I have missed a step, or done something wrong… But I don’t know where to start.

Does anyone recognise this behaviour and what do I need to do to fix it?
PLEASE is there anyone out there who can help?

Kindest regards,
Peter

2 Likes

That arc is part of linageos starup animation but it looks weird here ?

I see u used an older magisk build why ?

Go into twrp wipe the customrom dalvik cache

Now try it again this time try it without magisk and gapps just the custom rom see if it starts up if it does problem isnt the custom i am geussing magisk but i am no expert just try it do it agian and just flash linageos alone this time see if it starts up. if ti does startup download latest magisk it might be that. and flash magisk latest build

2 Likes

Thanks for taking the time to reply nemo.

The magisk version was the version I found at the URL in Max’s v-log.

I think the reason the graphic looks weird is because I tried to take a photo of a moving image. I probably should’ve made a movie instead. Unfortunately the forum won’t allow me to upload another attachment to show you, because I’m a new user.

To confirm, I have done everything you have asked…

  • From the TWRP menu, Tapped “Wipe”, then “Advanced Wipe”
  • Ticked “Dalvik / ART Cache”
  • Swiped “Swipe to Wipe”
  • when this had finished, Tapped the back arrow (<)
  • Tapped “Install”
  • Tapped “lineage-17.1-20210409-UNOFFICIAL-herolte.zip”
  • Swiped “Swipe to confirm Flash”
  • When the flash finished, tapped “Reboot”

Sadly, on reboot the result is the same…

  • Samsung Galaxy S7 logo
  • Black screen
  • Blue arc and blue circle animation
  • After about five minutes, phone boots into TWRP main menu

What have I missed in your instructions?
Assuming I did everything correctly, what else can I try?

Thanks again,
Peter

3 Likes

I would use LineageOS recovery for installing LineageOS, I had issues with Lineage when using TWRP in the past too.

2 Likes

Hi UIV,

Thanks for this. Where do I find LineageOS recovery? there not appear ro be a reference to it at: https://lineageos.org/ and the site does not seem to offer any kind of search functionality.

Moreover, assuming I can obtain a copy, how do I remove TWRP and install LineageOS recovery?

Regards,
Peter

2 Likes

Hey!

This was random. When I was unable to find a copy of Lineage Recovery I thought I’d try a “factory reset” and try everything from the beginning, only using the latest version of Majisk as suggested by nemo.

Interestingly, when the phone rebooted after the factory reset, instead of going back to a stock Samsung as I expected, it booted correctly into LineageOS 17.1 and I was able to complete set-up.

It doesn’t jhave majisk or Gapps, because they were removed at the advice of nemo.

I’m guessing I can install these now (majisk once I find the latest version).

Not sure how or why, but I think I’m good.

Obviously I’ll come crawling back with my tail between my legs if anything goes wrong.

Thanks guys,
Peter

2 Likes

Haha that’s great to hear! Get latest Magisk here : https://magisk.me/

App ZIP (Flashing) and APK (normal Install) are right there just scroll down.

Find your Lineage Device here: https://download.lineageos.org/
for future reference if you need it.

Also https://www.apkmirror.com/ is a great place to get literally any app. Though some apps require you download Via the Playstore to fully function.

1 Like

Glad it worked although your tekst confuses me sligthly
I think though it was magisk acting up and the (factory reset what do you mean by that) must have cleared it?

in your earlier post u said this
‘‘The magisk version was the version I found at the URL in Max’s v-log.’’

That video is older now apperntly doesnt get updated and thus outdated.
so now there are newer version out.

Yes now u can flash magisk and gapps

u can download latest magisk here at the official github page (for some reason the official xda thread has been closed.)

gapps do u know how that works ? u need right version for your phone u cant just select at random?

1 Like